使用Java EE SDK不能安装jdk

  • 2015-09-11
  • 浏览 (82)

今天在linux上安装使用maven3,用"mvn clean package"将web应用打包的时候提示说我的没有安装java或版本太低,是因为我的linux机器上只安装了jre,而打包需要用到jdk环境。于是就去网上找jdk来安装,在oracle的官网上看到有Java EE SDK,就下载了这个文件:java_ee_sdk-6u3-web-jdk7-linux-x64-ml.sh,执行的时候报下面的错误:


Could not locate a suitable jar utility.

Please ensure that you have Java 6 or newer installed on your system

and accessible in your PATH or by setting JAVA_HOME


这里说明Java EE SDK也依赖jdk,它自己也没有jdk。


原来是我理解错误了,Java EE SDK提供的是Java EE开发的工具,里面有glassfish等。


eclipse有Java SE和Java EE之分,web应用要安装Java EE的版本,误认为这次也要装Java EE SDK。


我们安装jdk用Java SE SDK就可以。

正文到此结束